After you download the crx file for FoxyProxy Standard 3.0.7.1, open Chrome's extensions page (chrome://extensions/ or find by Chrome menu icon > More tools > Extensions), and then drag-and-drop the *.crx file to the extensions page to install it.

FoxyProxy Basic: Switch your IP address with a single-click. Instructions here. FoxyProxy Standard: The original! Switch your IP address based on URLs and other rules or patterns. Instructions here. Pattern instructions are here. Instructions to use your proxy account with Firefox … Releases · foxyproxy/firefox-extension · GitHub Fixes so that FoxyProxy Basic can share the same codebase as FoxyProxy Standard again. Version number alignment: for the first time since FoxyProxy Basic was introduced, it will share the same version number as FoxyProxy Standard. Exported settings now include FoxyProxy edition -- Standard or Basic. However, they are interchangeable. FoxyProxy Basic version history - Add-ons for Firefox (en-US) Firefox 57+ is significantly different than previous Firefox versions. I was forced to re-write 10 years of mature FoxyProxy code from scratch. There are many missing features, and in almost all cases that is due to Firefox 57+ limitations or bugs (for example, custom-colored toolbar icons).

I do use a Master Password, but since you said it causes problems in Firefox 55 or earlier and I am on 66.0.4 I did not change the Master Password. What I meant was, Firefox 66.0.4 has a problem adding the certificate if your Master Password has not been updated since the old days when there was a separate popup window to create the master

FoxyProxy Basic version history - Add-ons for Firefox (en-US)

Getting sec_error_inadequate_cert_type with Private SSL

FoxyProxy Basic: Switch your IP address with a single-click.Instructions here. FoxyProxy Standard: The original!Switch your IP address based on URLs and other rules or patterns. Instructions here.Pattern instructions are here. Instructions to use your proxy account with Firefox … can't open some https websites | Firefox Support Forum Could you check your TLS level setting: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste TLS and pause while the list is filtered (3) If the security.tls.version.max preference is bolded and "user set" to some value other than 3, right-click it to restore the How to Set up a Proxy in FoxyProxy | Tutorial | Smartproxy